Answers for "sum of digits of a number in pythonus"

3

python sum of digits

def sum_digits(n):
    s = 0
    while n:
        s += n % 10
        n //= 10
    return s
Posted by: Guest on August-30-2020
1

find the digit number sum in a string in python

# Here, first a complex input is used to determine the sum of all the integers in that input.

# Rules : 1

s = input()
c = ""
for i in s:
    if i.isdigit():
        c += i
sum_d = sum(int(j) for j in c)
print(sum_d)

# Rules : 2

s = input()
c = ""
sum = 0
for i in s:
    if i.isdigit():
        c += i
for j in c:
  sum += int(c)%10
  c = int(c)//10
print(sum)

# Sample input: murad#123#$%&*$%!@*34
# Sample output: 13


# Eval method using to problem:
# Problem name: Python Evaluation
# Code
string = eval(input(""))
print()

# Sample Input: print(2 + 3)
# Sample Output: 5
Posted by: Guest on August-16-2021

Code answers related to "sum of digits of a number in pythonus"

Python Answers by Framework

Browse Popular Code Answers by Language