Answers for "sum of digits in a string"

1

find the digit number sum in a string in python

# Here, first a complex input is used to determine the sum of all the integers in that input.

# Rules : 1

s = input()
c = ""
for i in s:
    if i.isdigit():
        c += i
sum_d = sum(int(j) for j in c)
print(sum_d)

# Rules : 2

s = input()
c = ""
sum = 0
for i in s:
    if i.isdigit():
        c += i
for j in c:
  sum += int(c)%10
  c = int(c)//10
print(sum)

# Sample input: murad#123#$%&*$%!@*34
# Sample output: 13


# Eval method using to problem:
# Problem name: Python Evaluation
# Code
string = eval(input(""))
print()

# Sample Input: print(2 + 3)
# Sample Output: 5
Posted by: Guest on August-16-2021
0

sum of digits in a string

String -- sum of digits in a string
Write a method that can return the sum of the digits in a string
 


public  static int  sumOfDigits(String s) {
  int total = 0;
char[] ch =  s.toCharArray();
for(char each: ch) {
if(Character.isDigit(each)) {
total += Integer.valueOf(""+each);
}
}
return total;
}
Posted by: Guest on September-29-2021

Code answers related to "TypeScript"

Browse Popular Code Answers by Language